Welcome Guest Login or Signup
LIVE CHAT | INSTANT MESSENGER | BOOKMARK

FORUM
New Posts | My Topics | Profile Forum | User Settings | Subscriptions
Post Reply
GFI's tripping
Total Views: 997 - Total Replies: 4
Dec 17 2013, 7:56 pm - By Jimnkarens


We have not had a problem with our GFI's until yesterday. BOTH GFI receptacles are tripping out. Nothing new plugged in. Same stuff. Mostly cell phone chargers. When the chargers are not plugged in, no tripping. I thot the GFI might be worn out but both are tripping. Could both have worn out on exactly the same day? 
Livin on the "Bright Side"
Dec 19 2013, 2:09 am - Replied by: Technomadia


Are you plugged into shore power, generator or running completely off inverter/battery?
Cherie and Chris / Technomads / www.technomadia.com
1961 GM 4106 - Vintage Bus
On the road since 2006 

Dec 19 2013, 2:15 am - Replied by: Jimnkarens


Shore power
Livin on the "Bright Side"
Dec 19 2013, 4:53 am - Replied by: Technomadia


Is the shore power you are plugged into 50A, 30A or 15/20A GFCI?
Cherie and Chris / Technomads / www.technomadia.com
1961 GM 4106 - Vintage Bus
On the road since 2006 

Dec 19 2013, 11:34 am - Replied by: Jimnkarens


It is 30 amp. It seems that our GFI recepts trip whenever we have the cell phone chargers plugged into the plug strips but not when they are plugged directly into the GFI's. There must be a problem, ever so small, in both plug strips causing the fault.
Livin on the "Bright Side"
Post Reply

*** NuRVers.com ***